iOS pod导入环信SDK

官方文档写的是:
通过 Cocoapods 下载地址:
不包含实时语音版本 SDK(HyphenateLite)
pod 'HyphenateLite'
'HyphenateLite'包含实时语音版本 SDK(Hyphenate)
pod 'Hyphenate'
 
在我填写为 pod 'Hyphenate'后,执行pod install  报错 
[!] Unable to find a specification for `Hyphenate`
 
然后 pod reasch  Hyphenate
出现的内容如下, pod的时候 出现了两个账户 ,一个是HyphenateFull-SDK,一个是HyphenateFullSDK.请问哪个是官方的?为什么官方文档写的和实际不一样,如果实际的git地址修改了,为什么文档不做修改?(一只较真的程序员)
 
-> Hyphenate-SDK (3.1.5)
   An Objective-C client for IM service
   pod 'Hyphenate-SDK', '~> 3.1.5'
   - Homepage: https://github.com/HyphenateIn ... apods
   - Source:   https://github.com/HyphenateIn ... s.git
   - Versions: 3.1.5, 3.1.4.1, 3.1.4, 3.1.3.1, 3.1.3, 3.1.2 [master repo]

-> HyphenateFull-SDK (3.1.5)
   An Objective-C client for IM service
   pod 'HyphenateFull-SDK', '~> 3.1.5'
   - Homepage: https://github.com/HyphenateIn ... apods
   - Source:   https://github.com/HyphenateIn ... s.git
   - Versions: 3.1.5, 3.1.4.1, 3.1.4, 3.1.3.1, 3.1.3, 3.1.2 [master repo]

-> HyphenateFullSDK (3.1.4)
   An Objective-C client for IM service
   pod 'HyphenateFullSDK', '~> 3.1.4'
   - Homepage: https://github.com/easemob/hyp ... apods
   - Source:   https://github.com/easemob/hyp ... s.git
   - Versions: 3.1.4, 3.1.3, 3.1.2, 3.1.1 [master repo]

-> HyphenateSDK (3.1.4)
   An Objective-C client for IM service
   pod 'HyphenateSDK', '~> 3.1.4'
   - Homepage: https://github.com/easemob/hyphenate-cocoapods
   - Source:   https://github.com/easemob/hyphenate-cocoapods.git
   - Versions: 3.1.4, 3.1.3, 3.1.2, 3.1.1 [master repo]
已邀请:

lifei9241

赞同来自:

先执行一下pod setup 再pod install

要回复问题请先登录注册

知识价值的认可,源自您的赞赏

扫描二维码,你的支付将由imGeek代收后转给对方

×